QuickBooks Online: Error: "400 A Business Validation Error Has Occurred"
Issue
When syncing an invoice from Autotask to QuickBooks Online, you see the following error message in the Autotask Invoices app under Error Logs: "Error creating the QuickBooks invoice for Autotask invoice ID XXX and account 'XXX.' Reason: There was an error. 400 A business validation error has occurred while processing your request. Business Validation Error: Select a product or service The invoice number for Autotask invoice id XXX and account 'XXX,' was set to 'ERROR-XXX' in Autotask."
Cause
The matching items between Autotask and QuickBooks Online are not set to be sold to customers in QuickBooks Online. To map invoice items between Autotask and QuickBooks, you need to set them as items that are sold to customers.
For example, you might have an item with a material code of Shipping on your invoice, and an item with the same name in QuickBooks Online. The checkbox I sell this product/service to my customers. is unchecked for the item.
Resolution
- Edit the Item in Invoices > Products and Services.
- Check the I sell this product/service to my customers box.
Alternatively, you can rename or deactivate the item and create a new item by transferring the invoice from Autotask again.